Raspberry Pi Speedtest

# Pi Wi-Fi Speed Test

Okay guys, so I have been collecting Raspberry Pi’s here at my home
like crazy. I guess I just keep coming up with new projects to do,
and the Pi is perfect for the types of things I’m trying to do!
One of the oddities I’ve run into, however, is the stark difference
in Wi-Fi adapter speed between two different Pi 3 B’s I have.

These were both connected to the same SSID via the same AP from about
the same distance. In fact, the slower one was actually closer /
less obstructed.

Which as you’ll see here in a second, is very strange.

The following is my iperf tests from my desktop PC running
Ubuntu 17.10 to the aforementioned Pi’s. They were both running
the latest version of Raspbian (as of April 2018).

The Pi with the IP 192.168.178.62 (the slow one) I have setup with
Retropie as a college graduation gift for my little brother
(I know, I know, I’m a great brother, thanks 😃). The second Pi,
192.168.178.61 is running MagicMirror.

$(ndo@ndo3)-(~)-(11:20  Di Apr 03)->
$(jobs:0)-(32 files, 236Mb)-> iperf -s
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
[ 4] local 192.168.178.92 port 5001 connected with 192.168.178.62 port 40026
[ ID] Interval Transfer Bandwidth
[ 4] 0.0-10.1 sec 11.5 MBytes 9.56 Mbits/sec
[ 4] local 192.168.178.92 port 5001 connected with 192.168.178.62 port 40028
[ 4] 0.0-10.2 sec 15.3 MBytes 12.6 Mbits/sec
[ 4] local 192.168.178.92 port 5001 connected with 192.168.178.62 port 40030
[ 4] 0.0-10.3 sec 15.5 MBytes 12.6 Mbits/sec
[ 4] local 192.168.178.92 port 5001 connected with 192.168.178.62 port 40032
[ 4] 0.0-10.2 sec 12.3 MBytes 10.1 Mbits/sec
[ 4] local 192.168.178.92 port 5001 connected with 192.168.178.62 port 40034
[ 4] 0.0-10.2 sec 12.5 MBytes 10.3 Mbits/sec
[ 4] local 192.168.178.92 port 5001 connected with 192.168.178.61 port 33804
[ 4] 0.0-10.1 sec 46.0 MBytes 38.4 Mbits/sec
[ 4] local 192.168.178.92 port 5001 connected with 192.168.178.61 port 33806
[ 4] 0.0-10.1 sec 45.3 MBytes 37.7 Mbits/sec
[ 4] local 192.168.178.92 port 5001 connected with 192.168.178.61 port 33810
[ 4] 0.0-10.1 sec 43.8 MBytes 36.3 Mbits/sec

So my Retropie install was experiencing a 3x reduction in speed!

I experimented a bit to try to get to the bottom of it, but I didnt have the
time or the motivation to freshly install the OS, try a new SD Card, etc.

Fairly significant difference, though, huh?!